fix: pip in CI should be used into user mode

3 jobs for develop in 18 seconds (queued for 2 seconds)
Status Name Job ID Coverage
  Tests
failed qa-3.6 #5309
prod

00:00:10

failed qa-3.7 #5310
prod

00:00:03

failed qa-3.8 #5311
prod

00:00:03

 
Name Stage Failure
failed
qa-3.8 Tests
Requirement already satisfied: Mako in /home/gitlab-runner/.local/lib/python3.5/site-packages (from alembic>=0.7->flask_migrate->-r requirements.txt (line 5)) (1.1.3)
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
$ pip install --user -r requirements-dev.txt
ERROR: Could not find a version that satisfies the requirement black (from -r requirements-dev.txt (line 1)) (from versions: none)
ERROR: No matching distribution found for black (from -r requirements-dev.txt (line 1))
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
ERROR: Job failed: exit status 1
failed
qa-3.7 Tests
Requirement already satisfied: python-editor>=0.3 in /home/gitlab-runner/.local/lib/python3.5/site-packages (from alembic>=0.7->flask_migrate->-r requirements.txt (line 5)) (1.0.4)
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
$ pip install --user -r requirements-dev.txt
ERROR: Could not find a version that satisfies the requirement black (from -r requirements-dev.txt (line 1)) (from versions: none)
ERROR: No matching distribution found for black (from -r requirements-dev.txt (line 1))
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
ERROR: Job failed: exit status 1
failed
qa-3.6 Tests
Successfully installed Mako-1.1.3 SQLAlchemy-1.3.19 alembic-1.4.3 aniso8601-8.0.0 flask-admin-1.5.6 flask-login-0.5.0 flask-migrate-2.5.3 flask-restful-0.3.8 flask-sqlalchemy-2.4.4 flask-wtf-0.14.3 python-editor-1.0.4 wtforms-2.3.3
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
$ pip install --user -r requirements-dev.txt
ERROR: Could not find a version that satisfies the requirement black (from -r requirements-dev.txt (line 1)) (from versions: none)
ERROR: No matching distribution found for black (from -r requirements-dev.txt (line 1))
WARNING: You are using pip version 20.1.1; however, version 20.2.3 is available.
You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
ERROR: Job failed: exit status 1