Commit a7545b85 authored by Nicolas Joyard's avatar Nicolas Joyard

Update responsediff and fix dep versions

parent b9802f2d
......@@ -4,8 +4,6 @@ env:
language: python
python:
- '2.7'
before_install:
- pip install codecov
install:
- pip install -e .[testing]
before_script:
......
......@@ -10,36 +10,36 @@ setup(name='political-memory',
url='http://github.com/political-memory/political_memory/',
install_requires=[
'django-autocomplete-light>=3.0,<4.0',
'django-bootstrap3>=6.2,<6.3',
'django-bootstrap3>=6,<7',
'django-coffeescript>=0.7,<0.8',
'django-compressor>=1.6,<1.7',
'django-compressor>=1,<2',
'django-datetime-widget>=0.9,<1.0',
'django-filter>=0.11,<0.12',
'django-libsass==0.7.0',
'django-representatives-votes==0.0.16',
'django-representatives==0.0.22',
'django-filter>=0.13,<0.14',
'django-libsass>=0.7,<0.8',
'django-representatives-votes==0.0.17',
'django-representatives==0.0.23',
'django-taggit>=0.17,<0.18',
'django>=1.8,<1.9',
'djangorestframework>=3.2.0,<3.3.0',
'djangorestframework>=3,<4',
'hamlpy>=0.82,<0.83',
'ijson>=2.2,<2.3',
'python-dateutil>=2.4,<2.5',
'unicodecsv==0.14.1',
'pytz==2015.7',
'django-suit>=0.2.16,<0.3.0',
'sqlparse>=0.1',
'unicodecsv>=0.14,<0.15',
'pytz', # Always use up-to-date TZ data
'django-suit>=0.2,<0.3',
'sqlparse>=0.1,<0.2',
],
extras_require={
# Full version hardcode for testing dependencies so that
# tests don't break on master without any obvious reason.
'testing': [
'django-responsediff==0.2.0',
'flake8==2.5.1',
'pep8==1.5.7',
'pytest==2.8.5',
'pytest-django==2.9.1',
'pytest-cov==2.2.0',
'codecov',
'codecov>=2,<3',
'flake8>=2,<3',
'django-responsediff>=0.6,<0.7',
'pep8>=1,<2',
'pytest>=2,<3',
'pytest-django>=2,<3',
'pytest-cov>=2,<3',
]
},
entry_points={
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment