Embed resources of gafam-l10n repository from GitHub

parent deed19d1
......@@ -5,6 +5,7 @@ www.gafam.info CHANGES
in progress
-----------
- Embed resources of gafam-l10n repository from GitHub
2018-01-12 0.1.0
----------------
......
......@@ -106,6 +106,32 @@
</div>
</div>
<div class="column is-8">
<div class="card">
<header class="card-header">
<div class="card-header-title">
<div class="columns" style="width: 100%">
<div class="column is-7">
<div class="tags has-addons">
<span class="tag is-medium">Language</span>
<span class="tag is-medium is-primary">French, English</span>
</div>
</div>
<div class="column is-5">
<div class="tags has-addons">
<span class="tag is-medium">Format</span>
<span class="tag is-medium is-link">gettext PO</span>
</div>
</div>
</div>
</div>
</header>
<div class="card-content">
<div class="gafam-l10n"></div>
</div>
</div>
</div>
</div>
</div>
</section>
......
......@@ -26,14 +26,16 @@
"release": "webpack --config=webpack.release.config.js --display detailed --display-error-details --progress"
},
"devDependencies": {
"jquery": "^3.2.1",
"babel-polyfill": "^6.26.0",
"bulma": "^0.6.2",
"font-awesome": "^4.7.0",
"github-fork-ribbon-css": "^0.2.1",
"style-loader": "^0.19.0",
"css-loader": "^0.28.7",
"expose-loader": "^0.7.3",
"file-loader": "^1.1.5",
"font-awesome": "^4.7.0",
"github-embed": "^1.0.1",
"github-fork-ribbon-css": "^0.2.1",
"jquery": "^3.2.1",
"style-loader": "^0.19.0",
"webpack": "^3.5.6",
"webpack-dev-server": "^2.7.1",
"webpack-notifier": "^1.5.0"
......
......@@ -12,3 +12,7 @@
.site-header .subtitle {
line-height: 1.6em;
}
.gafam-l10n {
height: 44em;
}
......@@ -2,10 +2,41 @@ require('jquery');
require('font-awesome/css/font-awesome.css');
require('bulma/css/bulma.css');
require('github-fork-ribbon-css/gh-fork-ribbon.css');
require('babel-polyfill');
require('github-embed/npm/css/github-embed.css');
const githubEmbed = require('github-embed');
require('../css/main.css');
require('./version.js');
$(document).ready(function() {
// Propagate version
$('#version').html(__version__);
// Embed things from GitHub
githubEmbed('.gafam-l10n', {
"owner": "gafam",
"repo": "gafam-l10n",
"ref": "master",
"embed": [
/*
{
"type": "htmlpage",
"label": "Embedded HTML page",
"url": "https://github.com/gafam/gafam-l10n"
},
*/
{
"type": "po",
"label": "French original",
"path": "po/fr.po"
}, {
"type": "po",
"label": "English translation",
"path": "po/en.po"
}
]
});
});
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment