Commit 2c8217c4 authored by Okhin's avatar Okhin

Forcing django version in gitlab-ci

parent 67a4a34b
Pipeline #2428 failed with stages
in 3 seconds
...@@ -7,7 +7,7 @@ job test python: ...@@ -7,7 +7,7 @@ job test python:
script: script:
- virtualenv --python=python3 env - virtualenv --python=python3 env
- source env/bin/activate - source env/bin/activate
- pip install django - pip install django=='1.12.1'
- pip install coverage - pip install coverage
- python setup.py develop - python setup.py develop
- cp picampaign/settings.py.sample picampaign/settings.py - cp picampaign/settings.py.sample picampaign/settings.py
...@@ -47,7 +47,7 @@ job deploy preprod: ...@@ -47,7 +47,7 @@ job deploy preprod:
- rsync -ruvC ./ ${BASE_DIR} - rsync -ruvC ./ ${BASE_DIR}
- virtualenv --python=python3 ${BASE_DIR}/env - virtualenv --python=python3 ${BASE_DIR}/env
- source ${BASE_DIR}/env/bin/activate - source ${BASE_DIR}/env/bin/activate
- pip install django - pip install 'django==1.12.1'
- pip install coverage - pip install coverage
- python /srv/piphone/campaign/setup.py install - python /srv/piphone/campaign/setup.py install
- python /srv/piphone/campaign/manage.py migrate - python /srv/piphone/campaign/manage.py migrate
...@@ -66,7 +66,7 @@ job deploy prod: ...@@ -66,7 +66,7 @@ job deploy prod:
- rsync -ruvC ./ ${BASE_DIR} - rsync -ruvC ./ ${BASE_DIR}
- virtualenv --python=python3 ${BASE_DIR}/env - virtualenv --python=python3 ${BASE_DIR}/env
- source ${BASE_DIR}/env/bin/activate - source ${BASE_DIR}/env/bin/activate
- pip install django - pip install 'django==1.12.1'
- pip install coverage - pip install coverage
- python /srv/piphone/campaign/setup.py install - python /srv/piphone/campaign/setup.py install
- python /srv/piphone/campaign/manage.py migrate - python /srv/piphone/campaign/manage.py migrate
......
...@@ -6,7 +6,7 @@ here = os.path.abspath(os.path.dirname(__file__)) ...@@ -6,7 +6,7 @@ here = os.path.abspath(os.path.dirname(__file__))
README = open(os.path.join(here, 'README.md')).read() README = open(os.path.join(here, 'README.md')).read()
requires = [ requires = [
'Django==1.12.1', 'django',
'djangorestframework', 'djangorestframework',
'drf-nested-routers', 'drf-nested-routers',
'drfdocs', 'drfdocs',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment