Unverified Commit fb8a1eed authored by Conor Schaefer's avatar Conor Schaefer
Browse files

Install php mcrypt only on PHP 5 & 7.0

Pointed out by @aalaesar during review. In short, libmcrypt has been
obsolete since PHP 7.1 and removed since PHP 7.2. Therefore, we'll
preserve the installation of the package on older platforms
(specifically 5 & 7.0), but skip it on newer platforms (such as 7.2,
7.3). See for details [0].

[0] https://lukasmestan.com/install-mcrypt-extension-in-php7-2/
parent 8aee8821
......@@ -12,8 +12,6 @@
- "php{{ php_ver }}-json"
- "php{{ php_ver }}-curl"
- "php{{ php_ver }}-intl"
# Debian Buster lacks the php7.3-mcrypt package
- "{{ 'php'+php_ver+'-mcrypt' if php_ver != 7.3 else omit }}"
notify:
- start http
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment