Commit 682ce6a3 authored by njoyard's avatar njoyard Committed by GitHub

Merge pull request #33 from political-memory/fix-deps

Fix deps
parents 09be11f6 c5ceb990
sudo: false sudo: false
language: python language: python
env: env:
- DJANGO="django>1.8,<1.9" DJANGO_SETTINGS_MODULE=representatives.tests.settings - DJANGO_SETTINGS_MODULE=representatives.tests.settings
python: python:
- "2.7" - "2.7"
before_install: before_install:
- pip install codecov - pip install codecov
install: install:
- pip install $DJANGO pep8 flake8 pytest-django pytest-cov codecov django-responsediff - pip install -e .[api,testing]
- pip install -e .[api]
script: script:
- pep8 representatives/ --exclude migrations --ignore E128 - pep8 representatives/ --exclude migrations --ignore E128
- flake8 representatives/ --exclude migrations --ignore E128 - flake8 representatives/ --exclude migrations --ignore E128
......
...@@ -12,13 +12,23 @@ setup( ...@@ -12,13 +12,23 @@ setup(
license='GPLv3', license='GPLv3',
keywords='django government parliament', keywords='django government parliament',
install_requires=[ install_requires=[
'ijson', 'django>=1.8,<1.9',
'ijson>=2,<3',
], ],
extras_require={ extras_require={
'celery': 'celery', 'celery': 'celery',
'api': [ 'api': [
'django-filter', 'django-filter>=0.13,<0.14',
'djangorestframework', 'djangorestframework>=3,<4',
],
'testing': [
'codecov>=2,<3',
'flake8>=2,<3',
'pep8>=1,<2',
'pytest>=2,<3',
'pytest-django>=2,<3',
'pytest-cov>=2,<3',
'django-responsediff>=0.6,<0.7'
] ]
}, },
entry_points={ entry_points={
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment